Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Crysyn

      Only help if you can be helpful

      Hey All, A topic has come up of late in the IRC channel in regards to the general feel of the forums and the community that supports them. Things have progressed further than I would have liked with out this being addressed more publicly because I would much rather have snubbed this out sooner rather than later.. but I have been busy. Here is the general rule I would like people to follow: Wheaton's Law "Don't be a dick." Those of you from the IRC channel know that this is the only rule I ask people in there to follow and we generally have a good and lively time chatting about all manner of things. This is basic rule that just about everyone understands and I am going to expand it to the forums from here moving forward. If you can not help people in a helpful and polite manner then I simply ask you to stop. Now I generally take a back seat to moderating the forums as I like to participate in the suggestions forum fairly heavily at times and would rather do so as a forums user than a moderator. But I am also fairly well known for being the person who constantly puts their foot down and so I am stepping up and doing so on here. If you find yourself unable to respond to a message politely then I ask that you do not respond. This mostly focuses on the increasing level of hostility found within the Suggestion forum as well as the Server forum. I do not care if this is the 30th some odd time you have seen someone make the same suggestion. Or even if the new post on an older topic is one entry above the old one. I expect the members of this forum to respond politely to the user, new or old, and point to the older topic if it applies and even go the extra step to suggest they either add in new information or to summarize the outcome of the previous discussion based upon the new post's entry into it. That is what we are here for, that is why I close most topics instead of deleting them, so that they can be found and referenced down the road. The next topic is the slew of derailment attempts I have seen as of late. If you want to have fun and joke around that is what the off topic forum is for and pretty much anything goes there. I do not expect to read a suggestion thread and have to go through 3 pages of image memes people have shot back and forth. Quite simply this is a waste of my time to read and then have to clean up. Now for the summary. I am going to start taking a more active role, especially in policing the suggestion forum, and handing out warn levels to people whom I see doing this. These will be indiscriminate and applied not to just the first person who derails or is impolite on a topic or response, but to everyone whom follows the lead of that person. As I do not like doing things with out giving you all warning this post shall serve as that warning. If you have a desire to bring this topic up with me then I invite you to do so on the IRC channel. Lets raise the level of quality and grow the community. Let us not descend into the quality often found on the minecraft or league of legend forums. There is simply no need for that here. Be passionate about things, just do not be abusive.
    • Kittychanley

      Offline Servers

      Recently I've seen a few server listings showing up on the first page of the Servers forum that have been closed for an extended period of time, but have recently gotten a reply from a new member who didn't realize the server is offline. To help prevent this from happening in the future, it would be greatly appreciated if you could use the report function on the original post of any servers that have been confirmed as offline, so that the topic may be locked. If you are the admin of a server and plan on taking the server offline, please use the report function on the original post of your topic to let the TFC Staff know that the topic should be locked. If you are the admin of a server that has a locked topic, and would wish to bring the server back online, please use the report function on the original post of the topic to let the TFC Staff know that the topic should be unlocked. As always, please remember to follow rule #3 of the servers forum and update your topic title to contain the version of TFC that the server is currently running. You can do so by editing the OP, and then clicking on "Use Full Editor."
Sign in to follow this  
Followers 0
antimattergizmo

SMP .jar setup

25 posts in this topic

once I attempt to run the server .jar after installing the forge and TFC core, I get this error message

http://pastebin.com/8cqtrjJe

Please help I have asked several people who haven't responded at all.

edit: changed into url

Edited by antimattergizmo
0

Share this post


Link to post
Share on other sites

<space that used to have stupidity within>

Edited by antimattergizmo
0

Share this post


Link to post
Share on other sites

Did you delete the meta-inf if so dont do it.

0

Share this post


Link to post
Share on other sites

Did you install the following -> Minecraft Server Forge and TerraFirmaCraft into your server? If you installed more thats the problem!

0

Share this post


Link to post
Share on other sites

I feel like there's something that needs to be done where I read in the log that you need to make a mods folder. It doesn't seem to like the mods folder in your windowssystem32 folder which, iirc, windows7 throws some admin privs required or something back when you want to edit the contents of system folders. Not sure though since I don't host a server, I could be way off.

This may not actually be causing a problem though. I honestly don't know.

0

Share this post


Link to post
Share on other sites

I saw that and tried to make a mods folder within the same folder the jar was in, but it would not take it.

0

Share this post


Link to post
Share on other sites

Have you tried running the server with admin privs.?

0

Share this post


Link to post
Share on other sites

you forgot to add modloader to the jar as well...

0

Share this post


Link to post
Share on other sites

In all the tutorials I watched they did not have that part ._.

just tried executing it again and this time it properly downloaded a world folder, etc.

once everything is installed and I try to execute it the server never launches

Edited by antimattergizmo
0

Share this post


Link to post
Share on other sites

well you could try a fresh jar and do modloader, forge, TFC and textuers. That should do it.

Edit: actually I see what you did wrong. Try installing modloader, and run the server once that way, so the mods folder gets created, then install forge. Make sure you get the right version, I think it's 96, as well as the server one and not the client. Then install TFC and the texture files and you should be good. It looks like it was creating the mods folder in the system32 on your computer, which it shouldn't. What I do is make a folder on my desktop for the server. Then I put the jar file, and a bat file to start up the server. Then once I get all the files and folders, I start putting the other files in that are needed like modloader and forge.

0

Share this post


Link to post
Share on other sites

Do I need a bat file to run it? because I start with a fresh jar making sure the latest modloader and when I try to run the jar it flashes a loading mouse icon, but never does anything more

0

Share this post


Link to post
Share on other sites

nope, don't need a bat file. I just like it better than having to right click the jar and choosing to run it. I like how I have winrar open up the jar file on double click rather than running the jar file with double click.

0

Share this post


Link to post
Share on other sites

That's my format, double click for z-zip. Still no word on why I can't run it with right click in the first place though?

0

Share this post


Link to post
Share on other sites

well you should be able to right click and choose to run with java platform binary, or whatever it's called. I'd suggest using a bat file though because they're wicked simple to use.

0

Share this post


Link to post
Share on other sites

So nothing in terms of a fix has yet to be surmised? Running it via batch in no way could help.

0

Share this post


Link to post
Share on other sites

If you look at the error, it has a few things that pop up that don't make sense. It says you are using the wrong version of forge, and that the mods folder is somehow being created in the system32 folder on your computer. I think you are doing something wrong and just the error report isn't enough to go by. You should list exactly what you do, that might help.

0

Share this post


Link to post
Share on other sites

I will begin with what I said before in a bit more detail. I dowloaded a fresh jar from minecraft.net and put it into a folder on my desktop titled TFC. I then open the archive of said jar with 7zip and put the contents of a new, up to date modloader in the jar. You told me before to check it at that point, but when I attempt to execute the jar, it flashes a loading mouse icon and does nothing after.

0

Share this post


Link to post
Share on other sites

A couple things you could try:

-place your .jar in another location, some folder in a non-admin protected place on your computer that has nothing in it but your .jar

-make a .bat to start your jar; it's quick, painless, and you can create shortcuts to it and place them in easy-to-reach places

I'm running my server with just forge and the mod itself. It runs perfectly fine without modloader. (Honestly I just did what i do for current forge versions, which don't require modloader on the server and it worked, didn't even occur to me at the time that it might need it.)

Almost forgot: If you're unfamiliar with how to write a .bat just open a blank notepad file and write "java -Xms512M -Xmx1G -jar minecraft_server.jar" and make sure you change the file type, if you want more details on that you can find it here.

Good luck!

0

Share this post


Link to post
Share on other sites

Somehow it worked if only because I use that BAT file :D now I can stop prob. the longest support thread on here

0

Share this post


Link to post
Share on other sites

I just make a folder in my C: drive, though anything outside of the system files would probably be better

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0