Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Crysyn

      Only help if you can be helpful

      Hey All, A topic has come up of late in the IRC channel in regards to the general feel of the forums and the community that supports them. Things have progressed further than I would have liked with out this being addressed more publicly because I would much rather have snubbed this out sooner rather than later.. but I have been busy. Here is the general rule I would like people to follow: Wheaton's Law "Don't be a dick." Those of you from the IRC channel know that this is the only rule I ask people in there to follow and we generally have a good and lively time chatting about all manner of things. This is basic rule that just about everyone understands and I am going to expand it to the forums from here moving forward. If you can not help people in a helpful and polite manner then I simply ask you to stop. Now I generally take a back seat to moderating the forums as I like to participate in the suggestions forum fairly heavily at times and would rather do so as a forums user than a moderator. But I am also fairly well known for being the person who constantly puts their foot down and so I am stepping up and doing so on here. If you find yourself unable to respond to a message politely then I ask that you do not respond. This mostly focuses on the increasing level of hostility found within the Suggestion forum as well as the Server forum. I do not care if this is the 30th some odd time you have seen someone make the same suggestion. Or even if the new post on an older topic is one entry above the old one. I expect the members of this forum to respond politely to the user, new or old, and point to the older topic if it applies and even go the extra step to suggest they either add in new information or to summarize the outcome of the previous discussion based upon the new post's entry into it. That is what we are here for, that is why I close most topics instead of deleting them, so that they can be found and referenced down the road. The next topic is the slew of derailment attempts I have seen as of late. If you want to have fun and joke around that is what the off topic forum is for and pretty much anything goes there. I do not expect to read a suggestion thread and have to go through 3 pages of image memes people have shot back and forth. Quite simply this is a waste of my time to read and then have to clean up. Now for the summary. I am going to start taking a more active role, especially in policing the suggestion forum, and handing out warn levels to people whom I see doing this. These will be indiscriminate and applied not to just the first person who derails or is impolite on a topic or response, but to everyone whom follows the lead of that person. As I do not like doing things with out giving you all warning this post shall serve as that warning. If you have a desire to bring this topic up with me then I invite you to do so on the IRC channel. Lets raise the level of quality and grow the community. Let us not descend into the quality often found on the minecraft or league of legend forums. There is simply no need for that here. Be passionate about things, just do not be abusive.
    • Kittychanley

      Offline Servers

      Recently I've seen a few server listings showing up on the first page of the Servers forum that have been closed for an extended period of time, but have recently gotten a reply from a new member who didn't realize the server is offline. To help prevent this from happening in the future, it would be greatly appreciated if you could use the report function on the original post of any servers that have been confirmed as offline, so that the topic may be locked. If you are the admin of a server and plan on taking the server offline, please use the report function on the original post of your topic to let the TFC Staff know that the topic should be locked. If you are the admin of a server that has a locked topic, and would wish to bring the server back online, please use the report function on the original post of the topic to let the TFC Staff know that the topic should be unlocked. As always, please remember to follow rule #3 of the servers forum and update your topic title to contain the version of TFC that the server is currently running. You can do so by editing the OP, and then clicking on "Use Full Editor."
aleksey_t

[TFC 0.79.23+] Decorations Addon for TFC

100 posts in this topic

Check the config file for the server. That's what is set to have debugmode enabled, not your client.

Thanks but I checked on my server too: # Set this to true if you want to turn on debug mode which is useful for bug hunting. [default: false]

    B:enableDebugMode=false
 
Same in config for the client. I know I never enabled it and why does it go away as soon as I take out the decorations mod? If I put it back, the text is on top again.
 
Also, even odder, if I create a single player world, no text up top. Join back into my multiplayer world, text again...
 
I even went as far as getting a fresh copy of the .minecraft. No luck. I took out the weather mod thinking it was that since it was all weather readouts, no luck. I take out the decorations mod and it goes away. I also deleted my player profile from the server and logged in with a new player, still have the text. It is almost as if the decorations mod is triggering the debug mode despite it not being on.
Edited by crazz2323
0

Share this post


Link to post
Share on other sites

Any other advice please? That text is driving me crazy and debug mode is not set in server or player config :(

I even went back to a previous setup with minimal mods and DecoCraft still causes the text up top. I hate not to use Decocraft and no one else seems to have this issue so its not a known bug correct?

Edited by crazz2323
0

Share this post


Link to post
Share on other sites

Decocraft or decorations addon? They are very different things.

0

Share this post


Link to post
Share on other sites

Sorry, its in the original post i made.. [1.7.10]Decorations-1.0.20

 

I had to take the mod out, it also was causing crashing a null pointer error when right clicking with a stone in hand. This mod is not usable with  TFC 0.79.24816. Too bad.

Edited by crazz2323
0

Share this post


Link to post
Share on other sites

This is really cool!

1

Share this post


Link to post
Share on other sites

Seems like the latest version has a minor naming error on one file.

The AlabasterLight_blue.png is not found when the mod is loaded the file is currently named AlabasterLightBlue.png

I copied and added the file back into the jar as AlabasterLight_blue.png and it works now. Caps and lowercase had to be exact for the error to clear up.

0

Share this post


Link to post
Share on other sites

Due to a bug in how forge handles substitution aliases, which are used for gems in this addon, this addon partly breaks ore dictionary. The newest version of forge for 1.7.10 fixes this issue. Be aware not all mod/addons are compatible with newer versions of forge.

So either disable gem module in config, update forge or live with some recipe issues.

Edited by Bunsan
0

Share this post


Link to post
Share on other sites

Seems like the latest version has a minor naming error on one file.

The AlabasterLight_blue.png is not found when the mod is loaded the file is currently named AlabasterLightBlue.png

I copied and added the file back into the jar as AlabasterLight_blue.png and it works now. Caps and lowercase had to be exact for the error to clear up.

 

I have noticed there is a similar issue with the Rock Salt Mud Brick, though I do not know how to change it myself

0

Share this post


Link to post
Share on other sites

Anybody know what names should I put in the Dynamic Lights config file for the lanterns and gems to work?

0

Share this post


Link to post
Share on other sites

Anybody know what names should I put in the Dynamic Lights config file for the lanterns and gems to work?

 

If you install NEI and go to the in-game menu options, click on an option labled Data Dump, which downloads an Excel Sheet of all the item information, modded or vanilla. It's found in the new "data dumps" folder of your ".minecraft" folder. You can then plug those names into Dynamic Lighting's config options

1

Share this post


Link to post
Share on other sites

Just a quick question:

Is it correct for me to assume, that since the Deco mod is still in .79.23, it won't be compatible for .79.26?

0

Share this post


Link to post
Share on other sites

It still works in 26. 23 update had changed that broke addons.

0

Share this post


Link to post
Share on other sites

Having a slight issue. Gems appear to change to the Stone Button skin. I have tried with only TFC And Decorations, without all my mods, and still replicating the issue. Don't know if its maybe to do with more recent TFC updates causing the Gems to go obsolete. Any Ideas?

 

Edit: I have now found it works sometimes. Othertimes i get the button. Takes about 10 tries to get the actually gem to be on the wall and not the button.

Edited by Saiden
0

Share this post


Link to post
Share on other sites

Whenever I launch the game with this mod active it instantly closes, any help? :(

0

Share this post


Link to post
Share on other sites

Hey, I can't get it to work in my tfc server?

I'm using forge-1.7.10-10.13.4.1558

tfc: [1.7.10]TerraFirmaCraft-0.79.29.922

tried to use the 0.79.23 version too but didn't work at all. what am I doing wrong?

0

Share this post


Link to post
Share on other sites

Have you turned it off and on?

If you don't provide a crashlog or console log there is no way for anyone to know that is wrong. It does work as it is in both our packs and has worked fine. 

1

Share this post


Link to post
Share on other sites

A question about the lanterns: Do they run out of fuel like the TFC lamps do?

0

Share this post


Link to post
Share on other sites
On 27/11/2016 at 2:15 PM, ReignDance said:

A question about the lanterns: Do they run out of fuel like the TFC lamps do?

Nope. 

0

Share this post


Link to post
Share on other sites

You can also change config and decrease light emitted by these lantern. Light level similar to the redstone torch is a good choice IMHO.

0

Share this post


Link to post
Share on other sites

Do you never have to refill the lanterns? (If so, how do you do that?) 

 

Edit: I'm sorry, ignore this. I searched for refill instead of reading all the posts and missed that you already answered this. Thank you, sorry for missing that. 

 

Thanks,

Edited by rohan
Didn't read all the posts and didn't know my question was answered.
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now