Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Dries007

      Server Move   09/13/18

      I (Dries007) have recently taken over as main developer and server admin. This involved moving servers to reduce cost. It's likely there will be some more downtime in the future but most  things should be sorted by now. This forum is in dire need of replacement as the software is quite old and can't be easily updated. If you wish to discuss or stay updated, join our discord: https://invite.gg/terrafirmacraft. The forum will remain available to read, but will be locked in the future, when a new system is setup. The forum and wiki are now ad free. If you'd like to contribute to keeping it that way, you can do so via paypal or patreon.
Murry Folt

Rocks yield knives

9 posts in this topic

Just did a completely fresh install of TFC and started up a server to play on. Every time I went to gather a rock it would give me a zinc knife or nothing. The only other mod I have on is Matmos and that is client side only. Problem only persists on a SMP game, not a SSP one.

Already reported this bug, but decided to post here to see if there's a solution known. Maybe I did something wrong?

1

Share this post


Link to post
Share on other sites

This almost always happens when someone updates from one version to another and forgets to delete the config files.

But, you said that both the server installation and the client installation were fresh. So, I have no idea. You could check the config files on the client and the server, to see if they match.

0

Share this post


Link to post
Share on other sites

Evidentally my server install wasn't as fresh as I thought. Deleted old configs and it worked. My second time today overlooking a small, simple step.

0

Share this post


Link to post
Share on other sites

Do you know which type of rock it was, I've forgotten to convert and ended up with a chest full of zinc knives but couldn't remember for the life of me what was supposed to be in it.

0

Share this post


Link to post
Share on other sites

It happened with every type of rock I picked up. Not that I tried every kind, but there were no exceptions which I found.

0

Share this post


Link to post
Share on other sites

Do you know which type of rock it was, I've forgotten to convert and ended up with a chest full of zinc knives but couldn't remember for the life of me what was supposed to be in it.

Indvidual rock types are indicated by damage values, so it'll be any rock.

0

Share this post


Link to post
Share on other sites

Indvidual rock types are indicated by damage values, so it'll be any rock.

That's odd, some of my rocks were intact when I switched, it was probably something else then.

0

Share this post


Link to post
Share on other sites

That's odd, some of my rocks were intact when I switched, it was probably something else then.

There might be a couple different ID's or something (dirt, grass, and others are spread across 2 ID's), but there's definitely multiple rock types per ID.

0

Share this post


Link to post
Share on other sites

No, something else happened this time around, we deleted all configs, server and clients, and still got small ores for planks and knives for rocks. I also got a blue steel knife from my bronze knife.

The existing IDs got shifted, and that must be stabilised before it gets out of beta. No other mod has that problem.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now