Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Dries007

      Server Move   09/13/2018

      I (Dries007) have recently taken over as main developer and server admin. This involved moving servers to reduce cost. It's likely there will be some more downtime in the future but most  things should be sorted by now. This forum is in dire need of replacement as the software is quite old and can't be easily updated. If you wish to discuss or stay updated, join our discord: https://invite.gg/terrafirmacraft. The forum will remain available to read, but will be locked in the future, when a new system is setup. The forum and wiki are now ad free. If you'd like to contribute to keeping it that way, you can do so via paypal or patreon.
    • Dries007

      ATTENTION Forum Database Breach   03/04/2019

      There has been a breach of our database. Please make sure you change your password (use a password manager, like Lastpass).
      If you used this password anywhere else, change that too! The passwords themselves are stored hashed, but may old accounts still had old, insecure (by today's standards) hashes from back when they where created. This means they can be "cracked" more easily. Other leaked information includes: email, IP, account name.
      I'm trying my best to find out more and keep everyone up to date. Discord (http://invite.gg/TerraFirmaCraft) is the best option for up to date news and questions. I'm sorry for this, but the damage has been done. All I can do is try to make sure it doesn't happen again.
Engreyight

[Solved] Log Piles act strangely

6 posts in this topic

Have you read, understood, and followed all of the rules listed in large text at the top of the support forum? (Yes/No): Yes

 

TFC Version #: 0.79.21.741
 
Forge Version #: 10.13.4.1448
 
SSP/SMP (SinglePlayer/MultiPlayer): Single
 
Description: If I Shift + Right Clicking with a Log, it creates a Log Pile. Then I open it to place the other Logs in and strange things happen... (continues on the bottom)
 
Have you deleted your config files or are using default configs and are still able to reproduce this bug? (Yes/No): Yes
 
Do you have any mods other than Forge and TFC installed? (Yes/No): Yes
If yes, which mods?

  • PlayerApi
  • Smart Moving
  • Smart Render
  • CodeChickenCore
  • NEI
  • Fastcraft
  • Terrafirmacraft NEI plugin
  • Voxelmap
  • Liteloader

If you have Optifine or Cauldron installed, can you still reproduce the bug after uninstalling them? (Yes/No): I don't have them, so Yes.
 
Pictures:

...First all the logs go into the same slot.

Posted Image

Then I press Esc and reopen the Log Pile. (I didn't change anything)

Posted Image

It's just graphical. If I take it out it's back.

Posted Image

If I click 3 times on the Log Pile with Logs after creating it (a.k.a. I fill the first slot with 4 Logs) and then open it and shift click the remaining Logs it works as it should. If I grab the Logs (with Left Click) and put it into the slot or drag it, it places only 4.

Edited by Engreyight
0

Share this post


Link to post
Share on other sites

Just want to double check that I'm understanding what the issue is. So let me know if these are not the correct steps to reproduce it.

  • Sneak-click with a log to make a log pile.
  • Do not add any more logs to the pile by right-clicking on the pile with the logs.
  • Instead open the log pile interface, which currently only has 1 log inside.
  • Shift click the stack of logs into the log pile.

Is that correct? I can't reproduce the bug any other way. In other words, to avoid this from happening as a workaround that's actually how we expect to you to fill the pile anyways, just sneak-click with the first log to make the pile and hold right click with the rest of them to put them all into the pile without having to actually open the inventory, and they will properly go in with 4 in each slot.

 

I'll look into fixing this, but it's not a priority as it clearly states in large letters on the top of the support forum that bugs caused by shift-clicking within inventories will be generally just be "fixed" by just making it so you can't shift-click. In other words, shift-click at your own risk.

0

Share this post


Link to post
Share on other sites

Yes, the steps are correct. I can reproduce it with all the logs in all directions. This is the way I always did it, and it wasn't a problem in the previous version (0.79.20.710).

0

Share this post


Link to post
Share on other sites

http://terrafirmacraft.com/change_log.html

 

0.79.21 Change Log - "Cleaned up shift-click behavior to be more consistent across containers."

 

That change would have caused this, but I can't just revert that change for log piles because it will break some other behavior that was tweaked.

0

Share this post


Link to post
Share on other sites

This topic has been locked due to the vast number of replies that are breaking rule #7 of the support forum.

 

The issue has been solved for .22

1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.