Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Dries007

      Server Move   09/13/2018

      I (Dries007) have recently taken over as main developer and server admin. This involved moving servers to reduce cost. It's likely there will be some more downtime in the future but most  things should be sorted by now. This forum is in dire need of replacement as the software is quite old and can't be easily updated. If you wish to discuss or stay updated, join our discord: https://invite.gg/terrafirmacraft. The forum will remain available to read, but will be locked in the future, when a new system is setup. The forum and wiki are now ad free. If you'd like to contribute to keeping it that way, you can do so via paypal or patreon.
    • Dries007

      ATTENTION Forum Database Breach   03/04/2019

      There has been a breach of our database. Please make sure you change your password (use a password manager, like Lastpass).
      If you used this password anywhere else, change that too! The passwords themselves are stored hashed, but may old accounts still had old, insecure (by today's standards) hashes from back when they where created. This means they can be "cracked" more easily. Other leaked information includes: email, IP, account name.
      I'm trying my best to find out more and keep everyone up to date. Discord (http://invite.gg/TerraFirmaCraft) is the best option for up to date news and questions. I'm sorry for this, but the damage has been done. All I can do is try to make sure it doesn't happen again.
Cashleer

Having trouble installing OptiFine

21 posts in this topic

Hey It's me again (thenoobwhocantdoanythingalone). I watched several videos how to install OptiFine, but wasn't successful. I need OptiFine, because my game has some lagspikes, which are pretty random and are about 1-2 sec long, don't know why. Maybe Opti can fix this. I have everything working (forge,TFC) but can't install OptiFine. I tried opening the Forge in /versions, and copying all OptiFine files in there, but the launcher wouldn't start.. I would really like to play this mod smoothly and without lagspikes :> Edit: Is OptiFine capable with forge 10.0.837?Edit2: I managed to install it (wrong code in JVM arguments), but now Minecraft runs out of memory. I have 4. 095 MB memory.(cmd)Thank you for your time

0

Share this post


Link to post
Share on other sites

Are you using the Ultra version? I did and it worked.

 

Well, I did this. First, on Windows, you have to Show or hide file name extensions. Change the name of your optifine file from OptiFine_1.6.2_HD_U_B4.zip to OptiFine_1.6.2_HD_U_B4.jar

 

Then, I made folders in the /libraries/net folder: /net/optifine/optifine/1.6.2_HD_U_B4. In that folder, place the Optifine_1.6.2_HD_U_B4.jar.

 

After that, you open up your version (which should be a duplicate of Forge's version folder) folder and rename the jar and .json to whatever you named your version. Let's call it OptiForge.

 

Almost done. Open up the .json and change the id (at the bottom or top) to "OptiForge" or whatever your version is called. Also add this code:

{"name": "net.optifine:optifine:1.6.2_HD_U_B4","serverreq": false},

to line 8 of the .json.

 

Now, in your launcher, make a new profile and call it OptiForge. Make it use the version OptiForge, and add "-Dfml.ignorePatchDiscrepancies=true" after -Xmx1G. Make sure you add a space, otherwise, it will interpret it as a big long argument that doesn't exist. It should look like this:

 

-xmx1G -Dfml.ignorePatchDiscrepancies=true 

 

Yay! Optifine should work now!

0

Share this post


Link to post
Share on other sites

Are you using the Ultra version? I did and it worked.

 

Well, I did this. First, on Windows, you have to Show or hide file name extensions. Change the name of your optifine file from OptiFine_1.6.2_HD_U_B4.zip to OptiFine_1.6.2_HD_U_B4.jar

 

Then, I made folders in the /libraries/net folder: /net/optifine/optifine/1.6.2_HD_U_B4. In that folder, place the Optifine_1.6.2_HD_U_B4.jar.

 

After that, you open up your version (which should be a duplicate of Forge's version folder) folder and rename the jar and .json to whatever you named your version. Let's call it OptiForge.

 

Almost done. Open up the .json and change the id (at the bottom or top) to "OptiForge" or whatever your version is called. Also add this code:

{"name": "net.optifine:optifine:1.6.2_HD_U_B4","serverreq": false},

to line 8 of the .json.

 

Now, in your launcher, make a new profile and call it OptiForge. Make it use the version OptiForge, and add "-Dfml.ignorePatchDiscrepancies=true" after -Xmx1G. Make sure you add a space, otherwise, it will interpret it as a big long argument that doesn't exist. It should look like this:

 

-xmx1G -Dfml.ignorePatchDiscrepancies=true

 

Yay! Optifine should work now.

 

Trying this now. Should I rename the downloaded OptiFine file .rar? Or something else? EDIT: <--I fixed this nevermind

Edit 2 : http://i.imgur.com/dwCq3rC.png which one?

0

Share this post


Link to post
Share on other sites

Tried this but I keep getting this error, and yes I tried spelling it with your caps version and with the version suggested in the error... 

Gave up trying to download https://s3.amazonaws.com/Minecraft.Download/libraries/net/optifine/optifine/1.6.2_HD_U_B4/optifine-1.6.2_HD_U_B4.jar for job 'Version & Libraries'Job 'Version & Libraries' finished with 1 failure(s)!

 Any ideas? I may be confused about your instructions on the versions folder page. I don't see where you said to create a new folder under versions but you mentioned some duplicate folder so I just copied the forge one and renamed the folder, jar and json to Optiforge.

0

Share this post


Link to post
Share on other sites

You also need to change the id and add some code to line 8 that I posted in a spoiler. This new update...complicates things.

0

Share this post


Link to post
Share on other sites

I did that also. I think I figured it out though. Seems to work now.

 

 

I had to name the original file that I put in the libraries/net/optifine/optifine/1.6.2_HD_U_B4 folder from

 

OptiFine_1.6.2_HD_U_B4.jar

to

optifine-1.6.2_HD_U_B4.jar

 

Notice the lowercase "optifine" plus the dash instead of underscore right after "optifine"

0

Share this post


Link to post
Share on other sites

Alright. Glad you could get it to work. :)

0

Share this post


Link to post
Share on other sites

Thanks! Now to just setup my Smart Moving settings and try this new version out :)

0

Share this post


Link to post
Share on other sites

Good morning *Yawn*. Erm I am confused about the .json thingy. I only have 4 very long lines so it's not the 8th line for me(notepad)

Edit: If i set format to World Wrap I get around 16 lines. Is then this 8th line really the 8th line? Like here: http://i.imgur.com/nVavEFF.png  I should change the highlighted line?

0

Share this post


Link to post
Share on other sites

Use Word Pad if possible, it will give you a better layout. Put the above code right after this line...

	    {			"url": "http://files.minecraftforge.net/maven/,			"name": "net.minecraftforge:minecraftforge:9.10.0.xxx"		},
The beginning of the file should look something like this when done...

{	"minecraftArguments": "--username ${auth_player_name} --session ${auth_session} --version ${version_name} --gameDir ${game_directory} --assetsDir ${game_assets} --tweakClass cpw.mods.fml.common.launcher.FMLTweaker",	"libraries": [		{			"url": "http://files.minecraftforge.net/maven/,			"name": "net.minecraftforge:minecraftforge:9.10.0.xxx"		},		{			"name": "net.optifine:optifine:1.6.2_HD_U_B4",			"serverreq": false		},		{			"serverreq": true,			"name": "net.minecraft:launchwrapper:1.3"		},
Also, don't forget to change the id at the bottom of the json file.
0

Share this post


Link to post
Share on other sites

Use Word Pad if possible, it will give you a better layout. Put the above code right after this line...

	    {			"url": "http://files.minecraftforge.net/maven/,			"name": "net.minecraftforge:minecraftforge:9.10.0.xxx"		},
The beginning of the file should look something like this when done...
{	"minecraftArguments": "--username ${auth_player_name} --session ${auth_session} --version ${version_name} --gameDir ${game_directory} --assetsDir ${game_assets} --tweakClass cpw.mods.fml.common.launcher.FMLTweaker",	"libraries": [		{			"url": "http://files.minecraftforge.net/maven/,			"name": "net.minecraftforge:minecraftforge:9.10.0.xxx"		},		{			"name": "net.optifine:optifine:1.6.2_HD_U_B4",			"serverreq": false		},		{			"serverreq": true,			"name": "net.minecraft:launchwrapper:1.3"		},
Also, don't forget to change the id at the bottom of the json file.

 

 

Ok I did this, but now when I try to make a new profile and select version, it only shows the vanilla versions, no Forge no OptiForge(I renamed the files as said)

0

Share this post


Link to post
Share on other sites

You need to make a copy of the forge version and rename that folder to OptiForge. In that folder is where you change the name of the jar and json files and edit them. This way you have the 2 vanilla folders and the edited OptiForge folder.

0

Share this post


Link to post
Share on other sites

You need to make a copy of the forge version and rename that folder to OptiForge. In that folder is where you change the name of the jar and json files and edit them. This way you have the 2 vanilla folders and the edited OptiForge folder.

 

Ok will try it out, thank you :)

Edit: Error : Gave up trying to download https://s3.amazonaws.com/Minecraft.Download/libraries/net/optifine/optifine/1.6.2_HD_U_B4/optifine-1.6.2_HD_U_B4.jar for job 'Version & Libraries'

Job 'Version & Libraries' finished with 1 failure(s)!
0

Share this post


Link to post
Share on other sites

Make sure the jar file in libraries/net/optifine/optifine/1.6.2_HD_U_B4/  is named exactly like this...

 

optifine-1.6.2_HD_U_B4.jar

 

With the lowercase optifine and the dash after it instead of the underscore.

 

Hope that helps!

0

Share this post


Link to post
Share on other sites

So do I have to go through all this to make optifine work? They released a version that's supposed to be loadable by forge, but when I put it into the mods folder the game doesn't even open

0

Share this post


Link to post
Share on other sites

I've tried thic with ultra C4 version, it works but it starts a completely vanilla game

 

Oh nice, it looks like minecraft launcher can't see the optiforge version

0

Share this post


Link to post
Share on other sites

I've tried thic with ultra C4 version, it works but it starts a completely vanilla game

 

Ultra version doesn't always play nicely, but that should cause it to remove TFC loading.. are you sure you have both the TFC download and the Optifine download side by side in the same mods folder?

0

Share this post


Link to post
Share on other sites

I reeealy don't feel like typing and explanation on this, but I know of a much simpler way to do this, if anyone is still have trouble you can add me on skype and i'll walk you through it, my skype is murphyj_99

0

Share this post


Link to post
Share on other sites

I don't see a problem with all of the editing, my problem is very much more basic, in the profile editor you cannot just tell it to use Optiforge. Think we need more detail here then just "tell it to use OptiForge.

 

 

It only has the official versions listed and the version that forge installed.

0

Share this post


Link to post
Share on other sites

Copied directly from the Optifine's Minecraft Forums Post:

B. Simple (for OptiFine 1.6.2_C4 and newer)- Put the OptiFine JAR file in the Forge "mods" folder- Start Minecraft and Forge should automatically load OptiFine

So if you're using any version after 1.6.2_C4 (Ultra, Standard, Light, Whatever) you don't need to do anything extra with the profile. Just install forge and TFC the same way that you would if you weren't installing optifine, and then drop optifine in the mods folder. That's seriously all that is to it. You don't need to go editing jars or making Optiforge profiles or anything.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now