Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Crysyn

      Only help if you can be helpful

      Hey All, A topic has come up of late in the IRC channel in regards to the general feel of the forums and the community that supports them. Things have progressed further than I would have liked with out this being addressed more publicly because I would much rather have snubbed this out sooner rather than later.. but I have been busy. Here is the general rule I would like people to follow: Wheaton's Law "Don't be a dick." Those of you from the IRC channel know that this is the only rule I ask people in there to follow and we generally have a good and lively time chatting about all manner of things. This is basic rule that just about everyone understands and I am going to expand it to the forums from here moving forward. If you can not help people in a helpful and polite manner then I simply ask you to stop. Now I generally take a back seat to moderating the forums as I like to participate in the suggestions forum fairly heavily at times and would rather do so as a forums user than a moderator. But I am also fairly well known for being the person who constantly puts their foot down and so I am stepping up and doing so on here. If you find yourself unable to respond to a message politely then I ask that you do not respond. This mostly focuses on the increasing level of hostility found within the Suggestion forum as well as the Server forum. I do not care if this is the 30th some odd time you have seen someone make the same suggestion. Or even if the new post on an older topic is one entry above the old one. I expect the members of this forum to respond politely to the user, new or old, and point to the older topic if it applies and even go the extra step to suggest they either add in new information or to summarize the outcome of the previous discussion based upon the new post's entry into it. That is what we are here for, that is why I close most topics instead of deleting them, so that they can be found and referenced down the road. The next topic is the slew of derailment attempts I have seen as of late. If you want to have fun and joke around that is what the off topic forum is for and pretty much anything goes there. I do not expect to read a suggestion thread and have to go through 3 pages of image memes people have shot back and forth. Quite simply this is a waste of my time to read and then have to clean up. Now for the summary. I am going to start taking a more active role, especially in policing the suggestion forum, and handing out warn levels to people whom I see doing this. These will be indiscriminate and applied not to just the first person who derails or is impolite on a topic or response, but to everyone whom follows the lead of that person. As I do not like doing things with out giving you all warning this post shall serve as that warning. If you have a desire to bring this topic up with me then I invite you to do so on the IRC channel. Lets raise the level of quality and grow the community. Let us not descend into the quality often found on the minecraft or league of legend forums. There is simply no need for that here. Be passionate about things, just do not be abusive.
    • Kittychanley

      Offline Servers

      Recently I've seen a few server listings showing up on the first page of the Servers forum that have been closed for an extended period of time, but have recently gotten a reply from a new member who didn't realize the server is offline. To help prevent this from happening in the future, it would be greatly appreciated if you could use the report function on the original post of any servers that have been confirmed as offline, so that the topic may be locked. If you are the admin of a server and plan on taking the server offline, please use the report function on the original post of your topic to let the TFC Staff know that the topic should be locked. If you are the admin of a server that has a locked topic, and would wish to bring the server back online, please use the report function on the original post of the topic to let the TFC Staff know that the topic should be unlocked. As always, please remember to follow rule #3 of the servers forum and update your topic title to contain the version of TFC that the server is currently running. You can do so by editing the OP, and then clicking on "Use Full Editor."
EstebanLB

List of bugs for beta 2 build 49

45 posts in this topic

I'm using Forge build #248 and this mods:

Nei's Minimap

NEI

SmartMoving

OptiFine

Inventory Tweaks

3D items

  • Wooden Stairs and slabs are limited to the vanilla MC equivalent woods (damage values 0 to 3)
Posted Image
  • Stone anvil doesn't render the hammer left on top of it until the block is updated
  • Chisel mode is stuck at smooth and the changemode key doesn't work
  • Anvil dupes items clientside
  • Calendar doesn't show up
  • Metal anvils disappears when no hammer is left on them
  • If you use pickaxe on the stone anvil(on top side if hammer is rendered or any side if hammer is not rendered or not present) you get the old stone anvil item and you can then place it, but it won't have textures
  • Metal anvils and bellows don't display the hand animation when placed and are infinte(they does in creative, but not the full animation)
  • Bellows can't be used, no animation is shown when right clicked
  • Placing a Bloomery crashes the client and corrupts your save:
  • Scribing and metallurgy tables don't open the GUI when right cliked
  • Right-clicking on crafting table with a placeable block tries to place the block; if there's room, it places the block then removes it and then opens the crafting GUI. If there's no place or the block can't be placed(saplings, seed, flower, etc on stone), the GUI won't open
  • Sand blocks item shows white texture when hold in hand <- Unable to reproduce - Bioxx
  • The animation of falling dirt has no sound
  • Shovel (all tiers) digs sand at the same rate as punching
  • Logpiles stacks logs to 12 if right clicked <- Unable to reproduce - Bioxx
  • Prospector's pick doesn't work when right clicked on something
  • Sluices can't be placed
  • They don't replace tall grass either, it can be placed on top of it too <- Fixed in 49e - Bioxx
  • Calendar key cannot be changed or it won't work
  • None of the Anvils seems to work. The arrow won't move
  • Logs don't display the animation when placed first time to create the logpile, it does when adding logs to the pile <- Issue with MC - Bioxx
  • Placing rocks (cobble) doesn't have animation. <- MC Issue - Bioxx
  • Anvils don't make the smithing sound when buttons are pressed
  • New sand blocks are not compatible with the sluice nor the gold pan
  • Javelin throw is acting weird
  • Charcoal Pit doesn't produce smoke
Edited by EstebanLB
0

Share this post


Link to post
Share on other sites

Calendar worked fine for me and a bunch of others on the server I play on.

Also, I had the following crash: http://pastebin.com/LD1mgD94 (bearing in mind that I had a bunch of mods, OptiFine among them, installed at that time)

EDIT: Also, the stuff about wood is simply not yet implemented - that's not a bug.

Lastly, this is really what the BugTracker should be used for, not a forum post.

0

Share this post


Link to post
Share on other sites

  • Right-clicking on crafting table with smooth rock or rock bricks tries to place the block; if there's room, it places the block then removes it and then opens the crafting GUI. If there is not room (e.g. you are standing in the way, GUI does not open)

    • Reconfirmed issue in Build 49b
  • Shovel digs sand at the same rate as punching
  • New stone anvil has the collision box/mask of metal anvils even when rendering as slabbed block. Top texture doesn't update immediately (hammer texture not showing until unknown update event eventually causes it to show)

    • Texture update corrected (as per changelog); collision box still not matching render block
  • Vines in the air near willow trees
  • Changing key binding for chisel mode causes both keys (old mapping and new) to not work (restarting client reverts keymapping to default)

    • Reconfirmed issue in Build 49b
I will add these to the bug tracker later tonight when I have more time; just wanted to give Bioxx a heads up
0

Share this post


Link to post
Share on other sites

Anyone having problems with the stone axe and cutting down trees super slow?

Or when logging back into a save world the game putting you on top of whatever shelter you built?

0

Share this post


Link to post
Share on other sites

The animation of falling dirt has no sound.

1

Share this post


Link to post
Share on other sites

"Bellows can't be used, no animation is shown when right clicked" - not only that but they keep duplicating it when you put them on the ground

EDIT: wrong word

0

Share this post


Link to post
Share on other sites

Anyone having problems with the stone axe and cutting down trees super slow?

Or when logging back into a save world the game putting you on top of whatever shelter you built?

I've noticed that all axes are much slower now than B48; I suspect it was intentional.

0

Share this post


Link to post
Share on other sites

I simply can't craft zinc ingot at least on a stone (basalt) anvil with a stone hammer, I've tried every temperature from cold to faint red.

1

Share this post


Link to post
Share on other sites

I don't know if it was intentional, but in the Rolling Hills and Plains biomes, i haven't found any rocks. At all. I've had to go to beaches and such to find them. As well, you can't stack cooked pork anything unless you're doubling a stack. So you can stack one with another, but then to stack another one on, you have to have two, and and add the stack of two to the previous stack of two.

EDIT: Alright...something happened which fixed both...Probably just a client side issue, then.

And broken again...I don't understand.

0

Share this post


Link to post
Share on other sites

Log piles act pretty weird when shift clicking logs into them. I'm not sure if its inventory tweaks causing this or not but they stack more than they should.. Also the stone anvil has some updating issues.

Here's a quick video for clarification.

0

Share this post


Link to post
Share on other sites

The animation of falling dirt has no sound.

Is not a bug. Reinstall
0

Share this post


Link to post
Share on other sites

I can't seem to craft clay molds. derfuq?

0

Share this post


Link to post
Share on other sites

I can't seem to craft clay molds. derfuq?

Reinstall and delete configs
0

Share this post


Link to post
Share on other sites

I can't seem to craft clay molds. derfuq?

That I could do...

0

Share this post


Link to post
Share on other sites

  • Bellows can't be used, no animation is shown when right clicked
Why was it removed?
0

Share this post


Link to post
Share on other sites

can't load 49(a) on 49b

---- Minecraft Crash Report ----

// Uh... Did I do that?

Time: 05/09/12 23:05

Description: Exception in server tick loop

java.lang.ClassCastException: vp cannot be cast to TFC.WorldGen.TFCWorldChunkManager

at TFC.WorldGen.TFCProvider.b(TFCProvider.java:36)

at xc.a(WorldProvider.java:45)

at up.<init>(World.java:219)

at gr.<init>(WorldServer.java:58)

at axv.a(IntegratedServer.java:52)

at axv.b(IntegratedServer.java:81)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:415)

at ep.run(SourceFile:539)

Relevant Details:

- Minecraft Version: 1.3.2

- Operating System: Windows 7 (amd64) version 6.1

- Java Version: 1.7.0_07, Oracle Corporation

- Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

- Memory: 7963521824 bytes (7594 MB) / 8232042496 bytes (7850 MB) up to 8232042496 bytes (7850 MB)

- JVM Flags: 2 total; -Xms8192M -Xmx8G

- FML: FML v3.0.183.356 Minecraft Forge 4.0.0.247 5 mods loaded, 5 mods active

FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available

Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available

mod_ReiMinimap [mod_ReiMinimap] ([1.3.2]ReiMinimap_v3.2_05.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available

mod_SmartMoving [mod_SmartMoving] (Smart Moving Client for ModLoader.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available

TerraFirmaCraft [TerraFirmaCraft] (TFCraft-Universal-Core-B2-Build49b.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available

- Is Modded: Definitely; 'forge,fml'

- Profiler Position: N/A (disabled)

- Player Count: 0 / 8; []

- Type: Integrated Server

0

Share this post


Link to post
Share on other sites

I don't know if it was intentional, but in the Rolling Hills and Plains biomes, i haven't found any rocks. At all. I've had to go to beaches and such to find them. ~Clipped~

I too am unsure if the lack of rocks is a bug or not. Seems all the plains biomes I spawn in are completely void of them. Kind of hard to start out without even the most basic of tools.

0

Share this post


Link to post
Share on other sites

I too am unsure if the lack of rocks is a bug or not. Seems all the plains biomes I spawn in are completely void of them. Kind of hard to start out without even the most basic of tools.

If you move out you will find, and you will notice a lot more surface minerals on the rocks you find.

High hills are a good place to start

0

Share this post


Link to post
Share on other sites

I still can't craft a f***ing zinc ingot on a stone anvil with a stone hammer

0

Share this post


Link to post
Share on other sites

Animals seem frozen...

Because those are photos, that's why they look frozen

Naaa, just kidding. That bug was present in build 48. There is a bug report in Mantis already

0

Share this post


Link to post
Share on other sites

I've tried everything, working on a steel anvil(a gift from creative mode), with a bismuth hammer(also creative), with every temp. the green arrow simply won't move...

0

Share this post


Link to post
Share on other sites

49c , I've had chests disappear after logging out then log back in.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now