Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Dries007

      Server Move   09/13/18

      I (Dries007) have recently taken over as main developer and server admin. This involved moving servers to reduce cost. It's likely there will be some more downtime in the future but most  things should be sorted by now. This forum is in dire need of replacement as the software is quite old and can't be easily updated. If you wish to discuss or stay updated, join our discord: https://invite.gg/terrafirmacraft. The forum will remain available to read, but will be locked in the future, when a new system is setup. The forum and wiki are now ad free. If you'd like to contribute to keeping it that way, you can do so via paypal or patreon.

EzrahKarotan

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About EzrahKarotan

  • Rank
    Freshly Spawned

Profile Information

  • Location
  1. I removed the mod, in favor of using cooking with TFC's pumpkins and melons; I still have the api in though, since I use it with industrialcraft. It seems this causes a crash however, I'm not entirely sure how, but I believe it's more related to the plants api than the pumpkins mod itself [what is happening specifically, is that it appears with the pumpkins mod removed, but the api in tact, the pumpkins and melons in world that have already spawned aren't removed, they're still there, just invisible; and when you mouseover them, waila throws a null reference error and force closes the server, then crashes the game, I can get around it by temporarily disabling waila, going into the game, and breaking the invisible plant; but who knows howmany leftovers there are.]
  2. I'm having an issue with the mod; not a big one, it can be managed, but some sort of update would be useful/helpful. I'm using a rather large modpack, and it loads correctly and everything. But, every time on boot, the mod sets the injecteddependencies.json fileto change the relation to the 'debug' mod [FML debugger] to 'before' [meaning the mod tries to load before the debugger], which causes a crash. This doesn't cause a crash on the boot that the mod does the change, since in that instance the debug module is loaded correctly/first, but if you reboot your minecraft client without going back into the json and changing that particular entry back to 'after', the next boot results in a loop which crashes the mod load order module of forge itself. It appears that the tweaks mod is written to load itself before all other mods except TFC itself, and perhaps the debug module doesn't come up unless there are a large number of mods, but it should be fixable by whitelisting the mod, or having it ignore it by default, so that it returns to it's default load order as part of the forge package.
  3. WIP [TFC-0.79.29] TerraFirmaProgressivePack

    Getting an error, and can't launch. has to do with fluorite Fixed the error, the 'customitems:(orename)' scheme in the IC2.ini wasn't working, replaced them with oredict versions and it worked, got another error with duplicated block definitions though. concerning 'dark_quarzt_pillar', 'dark_quartz', and 'chiseled_dark_quartz' from defaultConfig-blocks.json and'red_sandstone', 'chiseled_red_sandstone', 'smooth_red_sandstone', 'red_sandstone_slab', 'red_sandstone_stairs', 'prismarine', 'prismarine_bricks', 'dark_prismarine', 'sea_lantern'fromdefaultConfig-1.8.json, which were fixed by removing the respective entires in the respective files. (moved them to an errata text file which will be ignored by custom items in case doing so causes some problems, but they appear to be initialized somewhere else within the mod, though I can't find where.) Getting some new errors now, but I'll try to fix them myself first. I'm getting some new ones now, but I'll try to fix them myself. Unable to resolve them, seems like some items that should of been defined aren't, I don't precisely know why, any help would be appreciated. the first one is for oil [specifically ihl:fluidoil being an invalid block type] and for prismarine crystals drop from ghasts, via the mob properties mod [the files for this were taken from the configs folder on the website, and finally a null pointer exception from ihl. I'll put that portion of the errorlog in a spoiler below Fixed it, by rolling some of the stuff I was working on [was trying to update some of the stuff to get rid of potential bugs by updating some of the mods] back and removing another mod by the creator of mobproperties, apparently some of the updates and blockproperties don't play nice together.