Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to TerraFirmaCraft Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Dries007

      Server Move   09/13/18

      I (Dries007) have recently taken over as main developer and server admin. This involved moving servers to reduce cost. It's likely there will be some more downtime in the future but most  things should be sorted by now. This forum is in dire need of replacement as the software is quite old and can't be easily updated. If you wish to discuss or stay updated, join our discord: https://invite.gg/terrafirmacraft. The forum will remain available to read, but will be locked in the future, when a new system is setup. The forum and wiki are now ad free. If you'd like to contribute to keeping it that way, you can do so via paypal or patreon.
Lavos5181

Change of comp makes server crash

9 posts in this topic

So my server crashed due to a state of engine being incorrect. I had copied a server from compA to compB. On compA it works fine and all. However on compB I get many errors and at the end, state of engine being incorrect error. Heres the error log http://pastebin.com/v7TPhuzj

I have already asked on forge site but they refuse to help. Thank you for the help.

the mods I am using are:
Decorations
merchants
terrafirmacraft
terramisc
TFCcellars
TFCudary
animalcrate
codechickencore
coroutil
farseek
fastcraft
hardcoredarkness
herdcraft
itemphysicsfull
minetweaker
multimine
myessentials
mypermissions
mytown2
playerapi
smartcore
smartmoving
smartrender
streams
tfctweaks
toomuchtime
weather

0

Share this post


Link to post
Share on other sites

Seems that you have different path to database, or SQL server is not installed/not working.

0

Share this post


Link to post
Share on other sites

Did you literally just copy from one computer to another and not rerun any installers? Forge support likes to ignore people when the solution is just to run the installer. 

0

Share this post


Link to post
Share on other sites

i literally copyied and did not rerun any installers im guessing the next part is to rerun the forge installer

 

0

Share this post


Link to post
Share on other sites

I had made a new forge server copied and the mods over to the new folder but still crash and does not make a reports folder

0

Share this post


Link to post
Share on other sites

I'm going to guess you just copied over the EULA.txt as well. It has to generate it and you have to edit it. You can't just copy it.

0

Share this post


Link to post
Share on other sites
2 hours ago, Bunsan said:

I'm going to guess you just copied over the EULA.txt as well. It has to generate it and you have to edit it. You can't just copy it.

I reinstalled a forge server which generated the new EULA I accepted the EULA copied the mods folder into the new servers mod folder the /fml confirm came up accept that and a short while after loading everything it crashed.

0

Share this post


Link to post
Share on other sites

I found the problem is with the config file but i do not know what in the config file is wrong. When i take the copied config file and add it in the server folder it crashes but when i run the server without the copied config it runs fine. Also no matter what a reports folder is never made.

0

Share this post


Link to post
Share on other sites
23 hours ago, Bunsan said:

I'm going to guess you just copied over the EULA.txt as well. It has to generate it and you have to edit it. You can't just copy it.

You can copy/paste the EULA.txt file between servers. It does not have to be generated.

Lavos' problem seems to be a missing database file:

[23:12:47] [Server thread/ERROR] [MyEssentials-Core/MyTown2]: java.sql.SQLException: path to 'H:\Users\Lavos\Desktop\TFC public/databases/MyTown2/data.db': '

H:\' does not exist

Change whichever config file is pointing towards H:\ to where you put the file on the new machine.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now